日刊 あおのうま Vol.2441(2017.12.07)【Win7なのでDocker は使えない】

投稿者: | 2017/12/07

VirtualBox と Vagrant

職場のVirtualBox を5.1 系から5.2 系にバージョンアップしたら、Vagrant の1.9 系が動かなくなりました。
対応バージョン外らしいです。

で、仕方なくVagrant も2.0 系に上げたら、今度は既存のbox ファイルが動かなくなりまして。
vagrant box update してもダメ。

結局、いちから環境を再構築中です。
あれこれ入れ直すの面倒くさい。

しかも新環境は各種ソフトもバージョンを上げねばならんのですが、これまたバージョン対応関係があっちこっちで合わないという有様。

環境構築はほんまに鬼門です。
ここいらをスムーズに出来る様になるだけで、随分と生産性はあがりそう。

Ansible とか、ちゃんと使えるよになりたいなあ。

この手の環境構築関係ハンズオンセミナーは大概が東京開催なんですよね。
大阪でも開催されないかなあ。

あー、あとWindows 7 環境でVagrant 2.0系以降を動かしたい場合は、PoweShell を5.0系以降にバージョンアップしておかないと、vagrant up からダンマリでビタいち動かなくなります。

正直、タイムアウトすら吐かずに固まるのはどうかと思う。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータがどう処理されているか知りたい方はこちらをお読みください